3D Animation

The Canterville Ghost

Der Anfang (The first 2 Min)

WHOW, jetzt habe ich mich lange nicht mehr gemeldet. Aber das Filmprojekt läuft. JAWOHL!
Ich möchte das Projekt unbedingt zu einem Abschluß bringen. Und ich arbeite zur Zeit hart daran. So .. es ist wie es ist .. sagt frei eure Meinung .. ich habe es so gut gemacht wie ich konnte.
Hier die ersten zwei Minuten. Und so kommt der 45- Minuten-Film auch raus.
(Engl.: That’s the current state of the project. I’ll end it up this year. It’s a amateure work, but i will finish it .. on what level ever. This are the first 2 min. Hope you like it.)

 

Advertisements

Layerbelegung

Im lauf meiner Arbeit mit Blender hat sich für mich da eine klare Aufteilung der Layer ergeben. Sie ist für die (äh . .na ja .. meine 🙂  ) Anforderungen der Animation optimiert.

Layerbelegung

Auf dem Layer Light/General befinden sich alle „festen“ Lichter und auf Light/Special die animierten (Helligkeit, Farbe, Position, etc), damit letztere leichter zu finden sind. Zusätzlich können Lichter auch auf den gesonderten Set-Layern sein (für Layer-Only Lamps). Auch auf den Charakter-Layern können Führungslichter für die einzelnen Charaktere sein. Diese sind ebenfalls meist  Layer-Only Lamps.


RenderPilot

Nachdem ich doch einiges an Renderläufen durchführen muss, habe ich mir ein kleines Programm geschrieben, das mir die Arbeit etwas abnimmt. Der RenderPilot.
RenderPilot
Damit lassen sich beliebig viele Joblisten führen, die wiederum mehrere Renderjobs beinhalten können. Mittels einer Zeitsteuerung laufen die dann über Nacht oder an Zeiten an denen der Recher dafür frei ist. Insbesonders das wiederholte Rendern von mehrfach überarbeiteten Szenen sind damit kein Problem mehr.

Als kleiner Nebeneffekt werden damit auch die Renderzeiten protokolliert. Und die reichen je nach Szene von 2 Stunden bis zu vier Tagen. Ich bin mal gespannt zu erfahren, wie lange ein komplettes Durchrendern des Films (also die Summe der Renderzeiten aller Szenen) so ergäbe.

Ergänzung:
Wer das Programm einmal ausprobieren möchte, hier die Links zum Download der Betaversion:
Programm: https://www.dropbox.com/s/ajjz9gigtie39f7/RenderPilot.exe?dl=0
Doc_Eng: https://www.dropbox.com/s/q4cinadencfeopo/RenderPilot_Eng.pdf?dl=0
Dok_Ger: https://www.dropbox.com/s/fs9vrkjaikqfsqk/RenderPilot_Ger.pdf?dl=0
Ein Hinweis: Die Dateien liegen in der Dropbox und diese fragt ggf. am Anfang nach einer Anmeldung. Einfach irgendwo daneben klicken und schon ist man beim freien Download.


Die Sache mit der Ölflasche

Ich bin noch dabei, die Szenen zu ‚finishen‘. Insbesonders die Animation braucht noch einiges an Politur. Dennoch will ich mal etwas mehr vom Film zeigen. Hier die Szene, in der das Gespenst seinen ersten Versuch startet die Parvenüs zu ertschrecken:  Die Sache mit der Ölflasche …


Es wird weiter getrickst

Noch arbeite ich an der Verbesserung der Animationen.  Inbesondere die Effekte machen noch einiges an Arbeit.

Zumindest sind die Sets final. Auch wenn diese zum Teil recht umfangreich geraten sind. Hier mal das Set des Kellergewölbes von Schloss Canterville.

Katakombe_400


Ein Touch von „Vom Winde verweht“

Lange habe ich schon nichts mehr geschrieben hier im Blog. Aber das nur weil ich mittlerweile fast täglich an der Fertigstellung des Films arbeite. Am letzten Wochenende wurde dann auch die kleine Szene mit dem Begräbniszug endlich fertig.  Beerdigung3
Sie ist nur klein, so an die 12 Sekunden, aber immerhin laufen 10 Personen dem Leichenwagen hinterher, dazu noch zwei auf dem Kutschbock sitzenze Lakaien sowie zwei dahintrottende Pferde. Ne Menge Walkcycles. Das ganze findet im Abendrot statt, was mich beim Betrachten der Szene irgendwie an eine ähnliche Einstellung aus „Vom Winde verweht“ erinnerte. Na ja, eine Abschiedsszene darf auch etwas Kitsch wagen.


Die Zeit läuft aus dem Ruder

LordC_Gallery_weitSeit jüngster Zeit habe ich schwere Probleme mit dem VSE beim finalen Rausrendern meines Films. Der 3D-Animationsfilm ist jetzt 44:35 Min lang und besteht aus ca. 230 Einstellungen, die sämtlich mittels Blender-Intern in AVI-RAW gerendert wurden – allerdings teilweise mit v2.62 und zum Teil mit 2.68. Und diese Mischung macht wohl Probleme.

Zum einen ließ sicht plötzlich das Schnittfile nicht mehr in 2.62 laden. PANIK! .. ok, ich bin dann auf 2.68 umgestiegen und dann gings wieder. Aber …

Nachdem ich dann die Eröffnungsszene (ursprünglich mit 2.62 gerendert) nach einer Änderung erneut mit 2.68 renderte, war anschließend der Wurm drin. Im Testlauf im VSE war zwar alles in Ordnung, aber im fertigen Film (MPEG) lief der Ton korrekt aber das Bild mit ca. doppelter Geschwindigkeit. Ich tippte auf ein Timecode-Problem (welches Blender ja schonmal hatte).

Und tatsächlich, als ich die Szene mit VCDGear lud, zeigte das Teil jede Menge fehlerhafter Sync-Blöcke an. Blender, bzw. das FFmpeg hat da offensichtlich ein Problem. Alles herumspielen mit TimeCode/Proxy/etc. brachte nichts. Einzige Lösung: Mit VCDGear laden, reparieren lassen und wieder abspeichern. Dann liefs …

Von wegen … Jetzt rendert Blender 2.68 zwar Bild&Ton synchron raus, bleibt aber irgendwann nach 20 – 30 Minuten stehen -> Keine Rückmeldung. Stets an einer anderen Stelle. Mist! Blender sollte doch mit den selbst erzeugten Files klar kommen.

Wenns ganz blöd läuft, muss ich alle 230 Einstellungen nochmal mit v2.68 rendern … oh Heiliger Zarquon …

NACHTRAG: Durch einen Tipp bei Blendpolis.de konnte das Problem behoben werden. Ich schneide den Film jetzt mit der Blender-Version 2.66a – die hat die genannten Defekte offenbar nicht und arbeitet einwandfrei.

Ich hätte auf mich hören sollen. Wie ich bereits in einem Beitrag schrieb, scheue ich eigentlich jeden Blender-Versionswechsel während der Produktion. Das bringt meist zusätzlichen Ärger. Also zurück von 2.68 zu 2.66a!


Ziel in Sicht

OK, so sieht es  nun mal aus: Hier ein Bild aus der endgültigen(!) Fassung des Films. Das Gespenst bei einem seiner mitternächlichen Auftritte, kurz bevor das Unheil von oben hereinbricht.
Ghost_TwinMeeting
Nach langem (wirklich sehr langem) herumprobieren, habe ich diese Art der Beleuchtung gewählt. Ich kann nur hoffen, dass in den vielen Nachtszenen noch etwas zu sehen ist. Ich habe keinen Nerv mehr, daran herum zu wursteln … genug des Herumprobierens .. Diese Ausleuchtung ist jetzt endgültig! Basta!


Umstieg auf neue Blender-Version

Nachdem ich im April 2011 von der Blender-Version 2.4 auf 2.5 umstieg, dann im März 2012 auf 2.62 wechselte, muss ich nun wohl wieder upgraden.

Lange habe ich der 2,62 die Treue gehalten, auch wenn inzwischen neuere Versionen herauskamen. Bei der guten alten 2.62 wusste um die Stärken und Schwächen und war gewohnt ersteres zu nutzen und letzeres zu umgehen. Aber jetzt bin ich mit dem Projekt an die Grenzen von 2.62 gestoßen. Bei einigen, nachträglich „aufgemotzten“ Szenen (mehr Details , mehr Effekte, usw.) habe ich nun mit Abstürzen zu kämpfen.  Das Teil pakts nicht mehr.

Bislang habe ich den erneuten Umstieg herausgezögert, da Tests zeigten, dass man evtl. nicht mehr zurück kann. Ein mit Blender 2.65 (oder höher) gespeichertes File, können ältere Versionen ggf. nicht mehr lesen und stürzen ihrerseits ab.

Blender2.68_splash

Aber es muss wohl sein. Also ab jetzt gehts mit 2.68a weiter. Der SplashScreen zeigt übrigens ein Szenenbild aus dem Tube-Filmprojekt „Wires For Empathy“ von Bassam Kurdali, das mit Blender realisiert wird.


Kleinigkeiten machen die meiste Arbeit

Tja, wie heißt es: Kleinigkeiten machen die meiste Arbeit. Da wollte ich dem Geist in seiner Erscheiningsform als Skelett noch mal ein schönes Glühen verpassen und schon gibts Ärger. Der Halo istz plötzlich weg. Paravan4Dort wo hinter dem Skelett diese dunkelgrüne Fläche des Paravents ist, wird der Halo vollständig „geschluckt“. Das ist blöd, denn dadurch funktioniert der geplante Gag nicht mehr.

Zur Klarstellung: Das Skelett steht vor dem Paravent! Also sollte auch der ihn umgebende Halo vor der Stellwand zu sehen sein. Warum das nicht so ist? Keine Ahnung. Ob es etwas damit zu tun hat, dass diese Fläche teiltransparent ist?

Da werden ich mal die Kollegen im Blender-Forum fragen …


Waldsee

Hier ein Set, an dessen Verbesserung ich gerade arbeite. Virginia und ihr Verehrer reiten gemeinsam aus. Dabei kommen sie auch an einem Waldsee vorbei. Der erste Entwurf (siehe unten) gefiel mir überhaupt nicht mehr. Also wurde das Idyl fast völlig neu designed. Und so siehts jetzt aus:

Waldsee_3

Hier nochmal zum Vergleich die Vorversion.

Wasserfall4Alle Versuche, das Set zu „retten“, schlugen fehl. Irgendwie ist der Setaufbau misslungen.  Die Bäume sind zu grob geraten, die Blätter zu riesig, die Baumreihen zu langweilig, der Wasserfall zu steif und das Licht zu konfus.


Synchron-Schnittchen

Das Anlegen des Tons der einzelnen Szenen kann recht fisselig werden. Da muss ein Soundtake oft aufs einzele Bild genau plaziert werden. Nach einigen Versuchen habe ich mir Blender so konfiguriert, dass es mir die Arbeit erleichtert.Screen001Ein Wunsch bleibt dabei aber noch offen. Im unteren Teil habe ich die Bild- und Tonspuren und im mittleren Bereich den Courve-Editor zum Animieren der Bild- und Ton-Effekte (rosa Linie). Zwar sind in beiden Fenstern die grünen Cursor-Anzeigen stets synchron (zeigen also auf das gleiche Frame), aber die Fenster scrollen nicht synchron. Wenn ich in unteren Editor den sichtbaren Bereich nach rechts oder links scrolle, verschiebt sich der Inhalt des mittleren Fensters nicht mit. Und das bedeutet -> Ich dreh am Rad. Also am Mousewheel. Und  zoome, verschiebe, zoome, schiebe, zoome, usw. .. bis beide Fenster wieder die gleiche Filmstelle zeigen. Es wäre schön, wenns da eine Automatik gäbe … Man kann wohl nicht alles haben. 🙂


Na, wo haben wirs denn?

In seinem Lager für Gruseliges hat das Gespenst so einiges in petto. Wo waren nochmal die Schrumpfköpfe und die Leichentücher? Na ja, mal sehen ob er es bei der Beleuchtung findet. Ich bin immer noch dabei die Animationen zu überarbeiten und die Ausleuchtung zu korrigieren.
Katakombe101c
Wenns auf meinem Monitor gut aussieht, kanns auf einem anderen mal wieder zu dunkel sein. Na ja .. ich arbeite dran.


Wie du siehst, siehste nichts

In dieser Szene reiten Virginia und ihr Verehrer durch einen Wald bzw. Park. Da ich die Sequenz neu ausleuchte, sind die Charaktere nicht drin –  nur eines der Pferde, als Größenvergleich.

Park10b

Nun fiel mit auf, dass nachdem ich die Wassertextur animiert habe, die Spiegelung der Brücke im Wasser plötzlich so gut wie weg ist?! Sehr merkwürdig. Da werde ich wohl noch ein wenig herumschrauben müssen …

Aber die gute Nachricht ist, dass Blender auch mit den nun vollständig in voller Auflösung (HD) gerenderten Szenen keinerlei Probleme hat – und es sind immerhin mehr als 50.000 Frames, die -zig Gigabyte ausmachen! Respekt!


Wo Licht ist, ist auch …

Hier mal wieder ein kleines Update aus der Filmproduktion 🙂 Immer noch plage ich mich mit der Ausleuchtung dunkler Szenen. Nachdem ich beschlossen hatte, alles generell etwas heller auszuleuchten, damit man auch auf dunkler kalibrierten Bildschirmen etwas sieht, gibt es immer wieder Überraschungen. Zum Beispiel hier: CantervilleGhost_Film_OtisBedroom2Dies ist das Schlafzimmer von Mr. und Mrs. Otis. Nachdem ich zusätzliche Scheinwerfer eingefügt hatte, waren plötzlich unerwünschte Schatten da. Seit wann wirft denn eine leuchtende Petroleumlampe einen Schatten (links unter dem Bilderrahmen) ?

Uff .. da werde ich wohl mit der Umverteilung der Kulissen auf verschiedene Layer arbeiten müssen – plus getrennter (Layer-Only) Ausleuchtungen. Ob der Zuschauer es später zu würdigen weiß, welch kniffelige und langwierige Arbeit auch in einer nur 15 Sekunden langen Szene liegen kann?

Also husch, husch, raus aus dem Bett. Wir bauen das Schlafzimmer um …


Verdunkelungsgefahr

Nachdem ich eine zusätzliche Szene eingefügt habe, hatte ich auch ein zusätzliches Problem am Hals. Mir fehlte noch eine kurze Sequenz, in der zu sehen ist, wie sich die Familie Otis in ihre Schlafzimmer zurückzieht. Also her mit dem Flur-Set, alle Beteiligten reingestellt und Türen aufmachen lassen damit sie dahinter dann verschwinden. Anschließend soll das Licht im Flur erlöschen. Und da wurde es merkwürdig: Einige Gegenstände bekamen dann merkwürdige Flecken:

FlurAusleuchtung4

Da stimmt noch etwas nicht mit den Materialien oder der Beleuchtung. Ich arbeite dran …

NACHTRAG: Nachdem ich bei der Lampe, die  mit dem blauen Halo von links durchs Fenster scheint, das Häkchen bei Difuse weggenommen habe, ist der Fleck weg.

FlurLicht3


Die hat `nen Schatten!

Beim Versuch ältere Scenen etwas aufzumöbeln, zeigen sich neue Probleme. Offenbar stimmt nach der Konvertierung der Blender-Files von 2.49 auf das 2.62-Format etwas an der Ausleuchtung nicht mehr. So wirft Virginia beim Verlassen des Schlosses einen recht merkwürdigen Zweit-Schatten.  Rechts neben ihr, auf den Treppenstufen flackerts sonderbar (Hier ein Ausschnitt ohne Dirtmap und Efeu, damit es besser zu sehen ist):

[vimeo http://vimeo.com/57122792 w=590&h=332]

Das zeigt sich leider bei allen älteren Szenen, die Tagesausleuchtung haben.

Tests haben gezeigt, dass es nicht am Objekt liegt AUF DIE die Schatten fallen. Deren Normale sind korrekt. Irgendetwas stimmt offensichtlich mit dem Lampen nicht mehr. Wenn ich die gesamte Ausleuchtung verwerfe und komplett neu aufbaue, ist alles korrekt ?!? Aber das wäre der Wahnsinn, wenn ich alles nochmal machen müsste … uff … Mal sehen, ob die Kollegen auf  blendpolis.de eine Idee dazu haben.

NACHTRAG: Nachdem ich die Ausleuchtung völlig neu aufgebaut habe (alle Lampen gelöscht und neue eingefügt) ist der Fleck weg.

Virginia am Tor

Keine Ahnung, warum er entstand. Wahrscheinlich hatte es damit zu tun, dass ich für diese Szene eine vorhandene Szene mit Nachtausleuchtung hernahm und nur die Lampen in Farbe und Helligkeit verändert hatte ?!?

2. NACHTRAG: Nachdem das Problem erneut auftrat, konnte ich endlich den Grund finden: Es lag daran, dass eine Area- bzw. Hemi-Lamp eine Textur(!) hatte. Sobald ich die Textur entfernte, war das Flackern weg. Es ist wohl so passiert, dass ich zunächst einen Spot eingerichtet habe, dem eine Textur mitgab und dann den Spot zur Hemi-Lamp machte. Nach wie vor ist eine Textur beim Spot überhaupt kein Problem – aber bei Area/Hemi schon. Uff .. na jetzt weiss ich wenigstens wo man suchen muss.


Herbsttage in Canterville

In den letzten Tagen habe ich die Tagesausleuchtung mehrerer Szenen überarbeitet. Tja, es ist nicht nur duster in den alten Gemäuern. Vier der 22 Szenen spielen am helllichten Tage. Da hätten wir das Speisezimmer …

Esszimmer von Schloss Canterville. Originalausleuchtung.

Der bewaldete Hain von Schloss Canterville. Originalausleuchtung.

… oder den bewaldeten Hain neben dem Schloss. Das ideale Plätzchen für die Aquarell-malende Virginia.

Bei der letzten Einstellung gibts allerdings noch Probleme. Bei dem großen Baumstamm links im Bild erscheint im unteren Drittel eine Kette von hellen Punkten, die da nicht gewollt sind. Keine Ahnung woran das liegt. Da frage ich mal bei den Kollegen in Blendpolis.de nach.

NACHTRAG: Das Problem bei der Waldszene ist gelöst. Es lag an der verwendeten Baumrinde-Textur. Eine kleine Korrektur in den Offset-Einstellungen ließ die hässlichen Flecken verschwinden.


Düstere Katakomben

Das Wochenende habe ich mit der Überarbeitungen von Ausleuchtungen der dunkelsten Schauplätze meines Films verbracht: Die Katakomben von Schloss Canterville.

Ich bin mir immer noch nicht sicher, ob es zu dunkel ist und man auf einigen Monitoren später kaum etwas sehen wird. Aber wenns zu hell wird leidet die Stimmung … ?!

Hier einige Standbilder aus dem Film – in Originalausleuchtung.




Grisseliges Feuer

Zurzeit kämpfe ich mit den kleineren und größeren Effekten im Film. Hier ist eine ältere Szene, die noch mit Blender 2.49b erstellt und gerendert wurde. Jetzt hatte ich mich entschlossen die alten Szenen alle nochmal mit 2.62 zu rendern und musste daher die Effekte anpassen. So auch die Feuer-Sachen.

Aber das mit dem neuen Smoke/Particle-System erstellte Feuer sieht in der Nahaufnahme etwas „grisselig“ aus, so als betrachte man es durch eine halbtransparente, stehende Sand-Textur. Blöderweise ist der Effekt nach dem Hochladen des Beispielvideos auf Vimeo nicht mehr so deutlich zu sehen (die rendern die Videos ja nochmal). Aber man siehts noch, wenn man auf die Ausläufer der Flammen schaut.

Mal sehen, was die Cracks der Blender-Community dazu meinen.

NACHTRAG: Die Ursache ist gefunden. Bei den Eigenschaften der SmokeDomain lässt sich unter „Integration“ der Wert „Step Size“ einstellen. Je kleiner dieser Wert, je feiner die Partikelübergänge/-ränder. Es scheint sich hier um eine Art Oversampling für Partikel zu handeln. Der Standardwert ist 0.200 – ich habe ihn auf ein Viertel reduziert und so bei 0.050 sehr schöne Flammen erzeugen können.